martes, 6 de abril de 2010

IE9.js para que Internet Explorer soporte los estándares

 Son varias las alternativas más avanzadas del CSS que aún no han sido implementadas en el navegador Internet Explorer, aunque algunas de ellas llevan ya un tiempo funcionando en la versión más reciente de IE8 y se mejorarán en IE9. Para hacer frente a estas y otras carencias, convirtiendo a IE en un navegador compatible con los estándares, el programador y diseñador de webs Dean Edwards ha creado una serie de scripts que podemos cargar directamente desde nuestra plantilla, sin necesidad de tenerlos que alojar nosotros personalmente. La última versión de la librería JavaScript IE7.js/IE8.js/IE9.js se puede consultar en Google Code. No es necesario incluir en la plantilla los scripts IE7.js/IE8.js cuando se está utilizando IE9.js.

 Para utilizar este script, lo único que hay que hacer es añadir el siguiente código antes del elemento resaltado en rojo:
<!--[if lt IE 9]><script src="http://ie7-js.googlecode.com/svn/version/2.1(beta3)/IE9.js"></script><![endif]--> 
 </head>

1 comentario:

Soporte Técnico dijo...

Excelente post! interesante. Saludos